Konfigurasi Network Routing RIP (Simulasi Packet Tracer)
Ok… kali ini saya bahas mengenai RIP ( Routing Information Protocol) pada router Cisco. Langsung bahas percobaannya saja… teorinya belakangan. Saya ambil contoh kembali network sebelumnya, yang menggunakan static routing. Static routingnya diganti dengan RIP, sehingga nanti akan lebih mudah untuk melihat perbedaannya.
ROUTER JKT | ROUTER-SBY | ROUTER MTR | ROUTER-MLK | |
Fa 0/0 | 10.10.11.1/24 | 10.10.22.1/24 | 10.10.33.1/24 | 10.10.55.1/24 |
Fa 1/0 | – | – | 10.10.44.1/24 | – |
Comp User | Dhcp | Dhcp | Dhcp | Dhcp |
Fa 4/0 | 192.168.1.1/30 | 192.168.1.2/30 | 192.168.3.1/30 | 192.168.3.2/30 |
Fa 5/0 | – | 192.168.2.1/30 | 192.168.2.2/30 | – |
Untok konfigurasi interface dan DHCP, pada routernya, saya rasa sudah dicontohkan dan dijelaskan pada posting sebelumnya tentang static routing. Jadi bisa dilihat sendiri pada postingan sebelumnya, dan tidak perlu saya bahas lagi disini. Langsung saja pada bagian konfigurasi RIP nya.
ROUTER-JKT.
ROUTER-JKT>en
ROUTER-JKT#config ter
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER-JKT(config)#router rip
ROUTER-JKT(config-router)#version 2
ROUTER-JKT(config-router)#network 192.168.1.0
ROUTER-JKT(config-router)#redistribute connected
ROUTER-JKT(config-router)#no auto-summary
ROUTER-SBY
ROUTER-SBY>en
ROUTER-SBY#config ter
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER-SBY(config)#router rip
ROUTER-SBY(config-router)#version 2
ROUTER-SBY(config-router)#network 192.168.1.0
ROUTER-SBY(config-router)#network 192.168.2.0
ROUTER-SBY(config-router)#redistribute connected
ROUTER-SBY(config-router)#no auto-summary
ROUTER-SBY(config-router)#do wr
Building configuration…
[OK]
ROUTER-MTR
ROUTER-MTR>EN
ROUTER-MTR#config ter
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER-MTR(config)#router rip
ROUTER-MTR(config-router)#version 2
ROUTER-MTR(config-router)#network 192.168.3.0
ROUTER-MTR(config-router)#network 192.168.2.0
ROUTER-MTR(config-router)#redistribute connected
ROUTER-MTR(config-router)#no auto-summary
ROUTER-MTR(config-router)#do wr
Building configuration…
[OK]
ROUTER-MLK
ROUTER-MLK>en
ROUTER-MLK#config ter
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER-MLK(config)#router rip
ROUTER-MLK(config-router)#version 2
ROUTER-MLK(config-router)#network 192.168.3.0
ROUTER-MLK(config-router)#redistribute connected
ROUTER-MLK(config-router)#no auto-summary
Sehingga secara keseluruhan, konfigurasinya adalah :
ROUTER-JKT
ROUTER-JKT#sh run
Building configuration…
Current configuration : 931 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER-JKT
!
!
!
ip dhcp pool lanjkt
network 10.10.11.0 255.255.255.0
default-router 10.10.11.1
dns-server 10.10.11.1
!
!
!
!
!
interface FastEthernet0/0
description LAN JAKARTA
ip address 10.10.11.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
description WAN JAKARTA TO SURABAYA
ip address 192.168.1.1 255.255.255.252
!
interface FastEthernet5/0
no ip address
shutdown
!
router rip
version 2
redistribute connected
network 192.168.1.0
no auto-summary
!
ip classless
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
ROUTER-SBY
ROUTER-SBY#sh run
Building configuration…
Current configuration : 986 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER-SBY
!
!
!
!
!
ip dhcp pool LAN-SURABAYA
network 10.10.22.0 255.255.255.0
default-router 10.10.22.1
dns-server 10.10.22.1
!
!
!
!
interface FastEthernet0/0
description LAN SURABAYA
ip address 10.10.22.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
description WAN SURABAYA TO JAKARTA
ip address 192.168.1.2 255.255.255.252
!
interface FastEthernet5/0
description WAN SURABAYA TO MATARAM
ip address 192.168.2.1 255.255.255.252
!
router rip
version 2
network 192.168.1.0
network 192.168.2.0
no auto-summary
!
ip classless
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
ROUTER-MTR
ROUTER-MTR#sh run
Building configuration…
Current configuration : 1148 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER-MTR
!
!
!
!
!
ip dhcp pool lanmtr1
network 10.10.33.0 255.255.255.0
default-router 10.10.33.1
dns-server 10.10.33.1
ip dhcp pool lanmtr2
network 10.10.44.0 255.255.255.0
default-router 10.10.44.1
dns-server 10.10.44.1
!
!
!
!
interface FastEthernet0/0
description LAN MATARAM 1
ip address 10.10.33.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
description LAN MATARAM 2
ip address 10.10.44.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
description WAN MATARAM TO MALUK
ip address 192.168.3.1 255.255.255.252
!
interface FastEthernet5/0
description WAN MATARAM TO SURABAYA
ip address 192.168.2.2 255.255.255.252
!
router rip
version 2
redistribute connected
network 192.168.2.0
network 192.168.3.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
ROUTER-MLK
ROUTER-MLK#sh run
Building configuration…
Current configuration : 929 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ROUTER-MLK
!
!
!
!
!
ip dhcp pool Lan-Maluk
network 10.10.55.0 255.255.255.0
default-router 10.10.55.1
dns-server 10.10.55.1
!
!
!
!
!
interface FastEthernet0/0
description LAN MALUK
ip address 10.10.55.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
description WAN MALUK TO MATARAM
ip address 192.168.3.2 255.255.255.252
!
interface FastEthernet5/0
no ip address
shutdown
!
router rip
version 2
redistribute connected
network 192.168.3.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Sedikit penjelasan tentang command konfigurasi RIP.
- router rip, mulai mengkonfigurasi routing RIP.
- version 2. Versi RIP yang baru. Biasanya versi baru kan harus lebih baik dari versi sebelumnya.
- network 192.168.1.0. Ingat yang dimasukkan adalah Network ID dari IP address si router yang terkoneksi dengan router lain yang akan menggunakan routing RIP.
- redistribute connected, Command ini ditambahkan karena ada beberapa IP address yang terkoneksi langsung dengan router, yang tidak menggunakan routing RIP. Contohnya seperti IP address dari user/computer yang langsung terhubung ke router
- no auto-summary, list / table routingnya akan dibuat terperinci, tidak dibuat secara umum. Lihat perbedaan antara “auto-summary” dengan “no auto-summary” dengan mengunakan perintah “sh ip route”.
Berikut contoh hasil “sh ip route” jika command auto-summary digunakan pada routing rip.
#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 10.0.0.0/8 [120/1] via 192.168.1.1, 00:00:04, FastEthernet4/0
C 10.10.22.0/24 is directly connected, FastEthernet0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet4/0
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, FastEthernet5/0
192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:11, FastEthernet5/0
R 192.168.3.0/30 [120/2] via 192.168.2.2, 00:00:11, FastEthernet5/0
Pastinya router akan bingung, untuk mengirimkan packet kemana, karena semua komputer pada contoh di atas menggunakan segmen IP class A, 10.0.0.0. dan pada table routing di atas hanya ada 10.0.0.0/8 via 192.168.1.1.
Berikutnya, di bawah ini hasil sh ip route, jika menggunakan command “no auto-summary”.
ROUTER-SBY#sh ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 5 subnets
R 10.10.11.0 [120/1] via 192.168.1.1, 00:00:16, FastEthernet4/0
C 10.10.22.0 is directly connected, FastEthernet0/0
R 10.10.33.0 [120/1] via 192.168.2.2, 00:00:18, FastEthernet5/0
R 10.10.44.0 [120/1] via 192.168.2.2, 00:00:18, FastEthernet5/0
R 10.10.55.0 [120/2] via 192.168.2.2, 00:00:18, FastEthernet5/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet4/0
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, FastEthernet5/0
192.168.3.0/30 is subnetted, 1 subnets
R 192.168.3.0 [120/1] via 192.168.2.2, 00:00:18, FastEthernet5/0
Terlihat jelaskan perbedaanya ? Jadi itulah kegunaan dari “no auto-summary”, akan dibuat table routing terperinci. Ok. Saatnya untuk mencoba, test ping dari salah satu komputer.
Sumber : https://myconfigure.blogspot.co.id/2013/11/konfigurasi-network-routing-rip.html